home *** CD-ROM | disk | FTP | other *** search
/ Chip 2007 January, February, March & April / Chip-Cover-CD-2007-02.iso / Pakiet bezpieczenstwa / mini Pentoo LiveCD 2006.1 / mpentoo-2006.1.iso / livecd.squashfs / var / db / pkg / x11-terms / xterm-207 / xterm-207.ebuild < prev   
Text File  |  2006-04-25  |  3KB  |  108 lines

  1. # Copyright 1999-2006 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # $Header: /var/cvsroot/gentoo-x86/x11-terms/xterm/xterm-207.ebuild,v 1.14 2006/02/10 14:50:35 seemant Exp $
  4.  
  5. inherit eutils flag-o-matic
  6.  
  7. DESCRIPTION="Terminal Emulator for X Windows"
  8. HOMEPAGE="http://dickey.his.com/xterm/"
  9. SRC_URI="ftp://invisible-island.net/${PN}/${P}.tgz"
  10.  
  11. LICENSE="X11"
  12. SLOT="0"
  13. KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 sh sparc x86"
  14. IUSE="truetype Xaw3d unicode toolbar doc"
  15.  
  16. RDEPEND="|| ( (    x11-libs/libX11
  17.         x11-libs/libXrender
  18.         x11-libs/libXt
  19.         x11-libs/libXmu
  20.         x11-libs/libxkbfile
  21.         x11-libs/libXft
  22.         x11-libs/libXaw )
  23.     virtual/x11 )
  24.     Xaw3d? ( x11-libs/Xaw3d )
  25.     doc? ( sys-apps/groff )
  26.     virtual/utempter"
  27.  
  28. DEPEND="${RDEPEND}
  29.     || ( x11-proto/xproto virtual/x11 )"
  30.  
  31. pkg_setup() {
  32.     if has_version ">=x11-base/xorg-x11-7.0.0_rc1"; then
  33.         einfo "Found $(best_version x11-base/xorg-x11)."
  34.         NEWAPPDEFAULTS=1
  35.         DEFAULTS_DIR="/usr/$(get_libdir)/X11/app-defaults"
  36.     else
  37.         einfo "Not found xorg-x11 version 7."
  38.         NEWAPPDEFAULTS=0
  39.         DEFAULTS_DIR="/etc/X11/app-defaults"
  40.     fi
  41. }
  42.  
  43.  
  44. src_compile() {
  45.  
  46.     filter-flags "-fstack-protector"
  47.  
  48.     econf \
  49.         --libdir=/etc \
  50.         --with-x \
  51.         --with-utempter \
  52.         --disable-setuid \
  53.         --disable-full-tgetent \
  54.         --disable-imake \
  55.         --enable-ansi-color \
  56.         --enable-88-color \
  57.         --enable-256-color \
  58.         --enable-broken-osc \
  59.         --enable-broken-st \
  60.         --enable-load-vt-fonts \
  61.         --enable-i18n \
  62.         --enable-wide-chars \
  63.         --enable-doublechars \
  64.         --enable-warnings \
  65.         --enable-tcap-query \
  66.         --enable-logging \
  67.         --enable-dabbrev \
  68.         --disable-narrowproto \
  69.         --with-app-defaults=${DEFAULTS_DIR} \
  70.         `use_enable toolbar` \
  71.         `use_enable truetype freetype` \
  72.         `use_enable unicode luit` `use_enable unicode mini-luit` \
  73.         `use_with Xaw3d` \
  74.         || die
  75.  
  76.     emake || die "failed to compile xterm"
  77.  
  78.     if use doc ; then
  79.         make ctlseqs.txt || die "failed to make documentation file"
  80.     fi
  81. }
  82.  
  83. src_install() {
  84.     make DESTDIR=${D} install    || die
  85.     dodoc README* INSTALL* ctlseqs.txt
  86.  
  87.     # Fix permissions -- it grabs them from live system, and they can
  88.     # be suid or sgid like they were in pre-unix98 pty or pre-utempter days,
  89.     # respectively (#69510).
  90.     # (info from Thomas Dickey) - Donnie Berkholz <spyderous@gentoo.org>
  91.     fperms 0755 /usr/bin/xterm
  92.  
  93.     # restore the navy blue
  94.     sed -i "s:blue2$:blue:" ${D}/etc/X11/app-defaults/XTerm-color
  95.  
  96.     # Fix for bug #91453 at Thomas Dickey's suggestion:
  97.     echo "*allowWindowOps:     false" >> ${D}/${DEFAULTS_DIR}/XTerm
  98.     echo "*allowWindowOps:     false" >> ${D}/${DEFAULTS_DIR}/UXTerm
  99.  
  100. }
  101.  
  102. pkg_preinst() {
  103.     # Prevent the terminfo files from being removed.  These collide with ncurses
  104.     # provided terminfo files.  So, now no more package collisions, yay!
  105.     touch ${ROOT}/usr/share/terminfo/v/vs100
  106.     touch ${ROOT}/usr/share/terminfo/x/x*
  107. }
  108.